By using AWS re:Post, you agree to the Terms of Use

can't connect to my instance

0

I'm using AWS RDP instance. In this instance RDP network setting, I manually changed my IP address through network adapter properties and change (TCP/ipv4) and click on apply. after that, I suddenly exit from RDP instance. then I try to reconnect again but I can't able to connect. I reboot my instance multiple time, I redownload my remote desktop file, but didn't work anything

it didn't connect to RDP so definitely no password issue. I got error message Error message

2 Answers
0

Hello,

If the instance is in a subnet that uses an AWS NAT Gateway, make sure that you're connecting to the instance's private IP address. The instance is unreachable on the public IP address behind the AWS NAT Gateway.

Verify that port 3389 isn't blocked Verify that port 3389 isn't blocked by your AWS security group, Network ACL, OS firewall, or antivirus software.

Confirm you're using the correct firewall and network configuration

  1. Open a PowerShell window from your local device, and then run the following command:

=> Test-NetConnection -ComputerName yourdomain.exampleco.com -Port 3389 2. In the output of the preceding command, verify that TcpTestSucceeded is True. This indicates that the EC2 instance is responding over the network and you can reach the required RDP port. For more information, see Test-NetConnection on the Microsoft website.

For EC2 checks, refer the below link: https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/troubleshoot-connect-windows-instance.html#rdp-issues -- [1]

SUPPORT ENGINEER
answered 2 months ago
0

solved.... I can't explain but, I'm from non technical field so its very hard to understand me. but after one day of research I solved this problem. first I actually remove my default public IP.(it's trick, search on google/YouTube) then I add a new elastic IP. then I add one new private IP through network interface option. then finally I bind these newly created two IP (elastic + private) together using elastic IP association setting. so now my default IP is already removed. so now I can access my instance through new elastic IP. which is now working like my public IP. that's it DONE.... my all inbound and outbound rules are defaults setting. I never need to edit/change it.

answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions