By using AWS re:Post, you agree to the Terms of Use

Unable to log into my MTurk requester account

1

Hi,

I get the following error when I try to login to my MTurk requester account with my AWS credentials (as an IAM user): "✖ There is a problem with your session. Please sign in again."

The login information is correct, since I am able to login to the aws.console.amazon.com page. I have also used this account with MTurk a year ago and had no issues, so this issue appears to be recent. Any suggestions on what could be going on here?

Thank you very much in advance!

  • I'm also getting this, becoming a real blocker:(

    with root user it works fine, but when using IAM with "AmazonMechanicalTurkFullAccess", getting this same error message

4 Answers
1

I am experiencing the exact same problem. Have tried many things, including create a new IAM User just for MTurk access. No dice. Same error as OP when trying to login at https://requester.mturk.com/signin_options. Would really appreciate any help. Thanks!

answered 9 months ago
1

Having this same exact issue. Ran through all the setup instructions and still unable to login with the IAM user you setup so you shouldn't have to hand out your root credentials. It seems like this was updated recently and is just broke. I get the same exact error as the poster. If i open a new tab and just go to the AWS console dashboard it actually says i'm logged in not that any services work because this IAM users has only TurkFullAccess>. I don't need the main AWS console i need the requester.mturk.com console.

answered 7 months ago
1

from aws-cs-mturk-requester-support-form@amazon.com at June 8th 2022 :

"From what you described, it seems you're trying to create a new MTurk account using IAM credentials. Please note that while it's possible to grant IAM access using API, new MTurk accounts can only be registered using root account credentials."

!!! And you have to be logged-out from AWS before!!!

answered 4 months ago
1

I am having this problem also. Accessing through https://requester.mturk.com/signin_options . When I AWS login as root user, I get "To sign in with an AWS account, please enable AWS Billing. First, sign in with your Amazon account and then navigate to the My Account page and opt in for AWS Billing." (I don't get this since as root user I already have access to Billing). When I login with IAMS username I get "There is a problem with your session. Please sign in again." I am still successfully accessing my account programmatically through the Mechanical Turk command line API. Any suggestions?

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions