started ubuntu lightsail instance which creates the folders with hostusername:psaserv , My sftp create files ubuntu username. NOW BOTH CLASHING

0

chown -R ubuntu:psaserv httpdocs <-- i can upload files to httpdocs but Plesk fails but after all uploaded when i make chown -R hostusername:psaserv httpdocs - plesk runs the site.

So every time i have to upload i change host director user to back and forth. its annoying. amazon provided user as ubuntu for ssh keys. Cant change to hostusername.

Anyone have a solution? Also another issue FTP do not work at all. ( it hangs on directory listing. It logs in.). if i can do ftp then this problem solved. Ftp username is hostusername.

Help pls.

alexk
asked 2 years ago287 views
1 Answer
0
Accepted Answer

I solved it.

  1. Add ports in firewall. example Custom TCP 21 22 184.65.143.85 SSH TCP 22 Any IPv4 address

Lightsail browser SSH/RDP DNS (TCP) TCP 53 Any IPv4 address

HTTP TCP 80 Any IPv4 address

HTTPS TCP 443 Any IPv4 address

Custom TCP 8443 Any IPv4 address

Custom TCP 8447 Any IPv4 address

Custom TCP 49152 65535 Any IPv4 address

DNS (UDP) UDP 53 Any IPv4 address

========================= 2. Choose explicit FTP over TLS (filezilla) to get directory listing work. Otherwise i am not getting directory listing.

But when ever i change file in SSH i change user after all done chown -R plesk_site_ftp_username:psaserv httpdocs.

alexk
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions