Mqtt broker not working in remote access

1

I have created an ec2 instance and install mosquitto broker on it and it working fine locally, both publishing and subscribing topics is working but it is not working remotely when I use the mqtt explorer no connection is establishing with broker, I have changed the config file also and listener and allow anonymous as I found on some help forum but still not working. I also edit the file with -c to force it to overwrite the previous one but still not working. If somebody can help me on it will be highly appreciable.

  • I am stuck in the same situation, did you figure it out @Zubair ?

Zubair
asked 8 months ago233 views
1 Answer
0

Check that the Security Group associated with your EC2 instance is allowing the ports and protocols used by your Mosquitto broker.

I would also suggest that you look into using AWS IoT Core instead of hosting and managing your own MQTT broker.

Have also a look at https://docs.aws.amazon.com/iot/latest/developerguide/what-is-aws-iot.html

AWS
EXPERT
answered 8 months ago
  • In the default settings ssh and source is custom, later I also added tcp and source is custom but still not working,

    Right now I am just experimenting with it, may be later I will explore aws iot core and will shift to it but before that I want to use mqtt broker

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions