By using AWS re:Post, you agree to the Terms of Use

ssh: connect to host ec2-...Operation timed out

0

When I try to connect to Instance ID i-040d4f154723b4691 I am getting an Operation timed out error.

I have checked NACL, Security Groups, everything else I have been able to find on this forum and elsewhere, with nothing working.

I also tried my other Instance ID i-0df833fed448e7cda and am having the same problem with it.

Edited by: GeoMc on Mar 9, 2020 11:39 PM

I ran the following test:
$ ssh -vvv -i "vid002.pem" ec2-user@ec2-52-9-144-44.us-west-1.compute.amazonaws.com
OpenSSH_7.8p1, LibreSSL 2.6.2
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 20: Applying options for *
debug1: Connecting to ec2-52-9-144-44.us-west-1.compute.amazonaws.com port 22.
ssh: connect to host ec2-52-9-144-44.us-west-1.compute.amazonaws.com port 22: Operation timed out

I checked and Port 22 is open for Inbound from my IP. I also opened it to 0.0.0.0/0.

It is still not working.

Is it possibly hung on the AWS end???

Edited by: GeoMc on Mar 10, 2020 3:39 AM

I added a rule to allow ICMP and tried pinging

Edited by: GeoMc on Mar 10, 2020 6:34 AM

asked 3 years ago812 views
1 Answer
0

My Subnet Route Table was pointing to my NAT instead of my IGW.

The answer was in the video at https://aws.amazon.com/premiumsupport/knowledge-center/instance-vpc-troubleshoot/

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions