By using AWS re:Post, you agree to the Terms of Use

Can't connect to a Apache Web Server (EC2 instance) http://ec2-54-255-32-232.ap-southeast-1.compute.amazonaws.com

0

I installed putty and Apache Web Server on my VPC EC2 instance (AWS Linux. But I can't connect to my newly created Apache Web Server by: http://ec2-54-255-32-232.ap-southeast-1.compute.amazonaws.com My Inbound rule: Type: SSH Protocol: TCP Port range: 22 Source: Custom: 0.0.0.0/0 But failed. Can you help me? Any idea?

  • I recommend that you don't put the DNS name (or IP address) of your instance on the forum. This is a public space and someone may use this information in a malicious way to attempt to compromise your instance.

6 Answers
0

Hello

You need to open port 80 HTTP so that you can access the apache page please check the security group, Here is the link helpful

answered 6 months ago
  • Thanks for your information provided. But still failed. I don't know how to handle this website issue.

0

Hi there,

It turns out most browsers try to resolve using SSL when URLs are opened even if you don't have an SSL configured on your server. That's why you are getting the error. To solve this, copy the IP to the browser directly or right click on the URL and choose the 'Go to option.' This will open the link without SSL.

answered 5 months ago
0

Thanks for your reply,. However, my AWS EC2 is a Linux server: Amazon Linux 2 AMI (HVM) - Kernel 5.10

How can I run telnet? Or is there any similar Linux command?

answered 5 months ago
  • Telnet is by far the easiest and simplest way to do this. Just install it: sudo yum install telnet

0

I have added 2 inbound rules:

IPV4, SSH, TCP, Port range: 22, Source: done by running https://checkip.amazonaws.com on my Windows 10 PC. IPV4, HTTP, TCP, Port 80, Source: 0.0.0.0/0

On the web server, I have already enable port 80 and port 443. Then I tested my Apache Web server by: http://ec2-99999999.xxxx.compute.amazonaws.com But still got the error: This site can't be reached. I have no idea about this issue and don't know in what way I should handle it. Please help me, thanks a lot.

answered 6 months ago
0

"To solve this, copy the IP to the browser directly or right click on the URL and choose the 'Go to option.' This will open the link without SSL."

Still failed. Same error: This site can't be reached.

answered 5 months ago
0

Some troubleshooting steps:

  1. On the instance, try doing telnet 127.0.0.1 80 (or 443 - up to you) and see if the session opens. That proves that the Apache server is running.
  2. For good measure, also try the same command to the local IP address of the instance: telnet 10.0.0.24 80 for example.
  3. Create another instance in the same subnet and perform that second telnet command from the other instance.

If all three work then I'm not sure what the problem is because the routing and the public IP clearly work because you can SSH to the instance.

However, I'm guessing that at least one of the three above will fail.

profile picture
EXPERT
answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions