Greengrass aws.greengrass.LogManager Invalid token while uploading logs


Hello All,

I am having and issue with aws.greengrass.LogManager on Greengrass, I have tried to redeploy, uninstall and deploy once again, but nothing helps. In greengrass.log I see that there was 3 attempts to run aws.greengrass.LogManager and all of them returned the same error:

2022-08-30T15:12:54.619Z [INFO] (pool-2-thread-83) Invalid token while uploading logs to /aws/greengrass/UserComponent/eu-central-1/com.example.Project-/2022/08/30/thing/Thing123. Retrying with the expected sequence token in CloudWatch response.. {} 2022-08-30T15:12:54.620Z [ERROR] (pool-2-thread-83) service-errored. {serviceNam=aws.greengrass.LogManager, currentState=RUNNING} java.lang.NullPointerException at java.util.concurrent.ConcurrentHashMap.putVal( at java.util.concurrent.ConcurrentHashMap.put( at at at$upload$0( at java.util.concurrent.ConcurrentHashMap.forEach( at at at at$handleStateTransitionStartingToRunningAsync$9( at java.util.concurrent.Executors$ at at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at

Configuration I am using: { "logsUploaderConfiguration": { "systemLogsConfiguration": { "uploadToCloudWatch": "true", "minimumLogLevel": "INFO", "diskSpaceLimit": "10", "diskSpaceLimitUnit": "MB", "deleteLogFileAfterCloudUpload": "false" }, "componentLogsConfigurationMap": { "com.example.Project": { "minimumLogLevel": "INFO", "diskSpaceLimit": "10", "diskSpaceLimitUnit": "MB", "deleteLogFileAfterCloudUpload": "false" } } }, "periodicUploadIntervalSec": "60" }

Would appreciate your help.

2 Answers

Hi, This exception is related to the PUT in concurrentHashMap, when either the key or value is null. Please check the logGroupName and logStreamName? Those information should also printed as logger message just before this error. The potential reason is logStreamName is null.

answered 2 years ago


Can you confirm that your Greengrass device role has the correct permissions set? I am wondering if this is a permission issue with Cloudwatch which results in an invalid token being used:

It may also be due to having multiple sources sending to the same log stream - see

If that does not resolve the issue, would you be able to provide the full log?


answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions