Lightsail Wordpress - Welcome to nginx!

0

Hi Everbody,

I have been using Bitnami Wordpress on AWS Lightsail for a year now. When I go the home page (www.connorpek.com), now it now says "Welcome to nginx!". I didn't change any configuration files in the terminal, and my wordpress content seems to be in the right file locations.

My Wordpress installation lives at the same file path as everybody else with Bitnami wordpress, which is home/bitnami/stack/wordpress. Research indicated my server isn't pointing my home page to the right file, which should be home/bitnami/stack/wordpress/index.php like everyone elses. Research also indicates I could make that change in the .htaccess file, but I am unable to locate that file in my Lightsail Bitnami Wordpress installation. Research also indicates the PHP logs would give me more detail, but I'm unauthorized to access files inhome/bitnami/stack/php/logs.

Thanks a bunch, Connor

asked 3 months ago32 views
2 Answers
0
Accepted Answer

Hi Gabriel,

Thanks for the insight. Yes somehow I downloaded Nginx and I had to disable it then boom, the website worked again. I disabled Nginx by using the following command before rebooting.

sudo update-rc.d -f nginx disable

After rebooting, Nginx doesnt show up on the list with either of the following commands.

sudo /opt/bitnami/ctlscript.sh status
ps aux | grep -i nginx
systemctl list-units

At this point the website started working. This problem was solved in part with assistance on Bitnami support people over on Githib.

Thanks a bunch, Connor

answered 3 months ago
0

The Bitnami WordPress image used on Lightsail works with Apache and PHP-FPM – not nginx. First disable nginx and confirm that apache is running, then try to access your site again.

Typically an index.php is the default file called for a given folder, so it's unlikely adding it explicitly would fix your issue.

The logs in home/bitnami/stack/php/logs/ are owned by root user so you need a command like sudo zless /home/bitnami/stack/php/logs/php-fpm.log-<date>.gz or just sudo less <some other non-gzipped log> for the most recent log files.

answered 3 months ago
  • Thank you for your attention Gaberial. We solved it between you and some Bitnami support folks on Github. I'll be left wondering how Nginx was downloaded to my server but it's all good.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions