How to prevent Windows LightSail RDP from going to sleep?

0

I have got an AWS Windows Server 2022 Lightsail instance with RDP access, and I require certain applications to run continuously on it. However, when I close the tab or RDP client, the RDP session enters sleep mode after 10 minutes, which disrupts my applications' functionality. I attempted to address this issue by modifying group policies, but I have yet to find a successful solution. Can you suggest alternative methods to prevent the RDP session from sleeping?

asked a year ago872 views
2 Answers
0

Can't the running application run in the background?
If we could run it in the background, it would be possible to keep it running even if the RDP session is out.

https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/start

profile picture
EXPERT
answered a year ago
  • no, it's like a browser window. I just want the RDP to stay on 24/7 without going to sleep

0

Your RDP connection is a remote session. When you close RDP client, the session is disconnected and will timeout.

You can configure your remote session not to timeout via Group Policy (gpedit.msc), i.e. Computer Configuration -> Policies -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Session Time Limits.

Change Set time limit for disconnected session and all the rest to Disabled.

It works for me on a Lightsail Windows 2022 instance.
I disconnected RDP session at 11:54am, and was able to connect back at 12:12 pm. As per below screenshot, the Group Policy settings are set to Disabled. Do verify your settings.

Enter image description here

AWS
EXPERT
Mike_L
answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions