Version Incompatibility between Lambda function and Greengrass Core

0

I am receiving the following error and am unsure of how to resolve it. I would appreciate if someone could point me to the relevant documentation.

[2019-05-22T12:43:49.542Z][FATAL]-lambda_runtime.py:356,Failed to initialize Lambda runtime due to exception: There was a version incompatibility between the Greengrass SDK used by your function [arn:aws:lambda:us-east-1:XXXXXXXXXXXX:function:GGLambda:2] and the Greengrass Core. Please visit the AWS Greengrass Developer Guide for version compatibility information

asked 4 years ago12 views
1 Answer
0

I created the Lambda function from a file and decided the file contents were the cause of the error so I rebuilt the function from scratch and deployed it. This eliminated the error condition.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions