Windows Server 2012 R2 - EC2AddRoute: Failed to find local area connection

0

Hi,

I have an issue with one of my ec2 instance ( Windows Server 2012 R2 ).

I have updated PV Drivers, EC2Config but now the instance dont pass status check. The message in de AWS Console is:
"Instance reachability check failed"

I can start it with c3.large instance type, but not with r4.xlarge.

The ec2config service log:

2019-01-02T14:09:35.671Z: EC2Config service starting...
2019-01-02T14:09:35.702Z: Legacy configurator starting...
2019-01-02T14:09:35.702Z: Legacy configurator started.
2019-01-02T14:09:35.718Z: Finding resources
2019-01-02T14:09:35.718Z: Done Finding resources
2019-01-02T14:09:35.734Z: Updating config files...
2019-01-02T14:09:35.749Z: Update config files completed.
2019-01-02T14:09:35.749Z: EC2ConfigMonitorState: 0
2019-01-02T14:09:35.780Z: Starting execution of script 'C:\Program Files\Amazon\Ec2ConfigService\Scripts\DiscoverConsolePort.ps1'.
2019-01-02T14:09:37.655Z: Driver: AWS PV Driver Package v8.2.5
2019-01-02T14:09:38.062Z: Opening COM1 port handle to write to the console
2019-01-02T14:09:38.109Z: Checking Configuration State of Windows before continuing
2019-01-02T14:09:38.109Z: Windows sysprep configuration complete.
2019-01-02T14:09:38.171Z: Warning: Unable to Publish to WMI. | System.Management.Instrumentation.WmiProviderInstallationException: Exception of type 'System.Management.Instrumentation.WMIInfraException' was thrown.
at System.Management.Instrumentation.InstrumentationManager.Publish(Object value)
at Ec2Config.LegacyConfiguration.LegacyConfigurator.PublishWmiInstance()
2019-01-02T14:09:38.187Z: Checking for Sysprep
2019-01-02T14:10:01.061Z: AMI Origin Version: 2016.05.11
2019-01-02T14:10:01.077Z: AMI Origin Name: Windows_Server-2012-R2_RTM-English-64Bit-Base
2019-01-02T14:10:01.124Z: OS: Microsoft Windows NT 6.3.9600
2019-01-02T14:10:01.124Z: OsVersion: 6.3
2019-01-02T14:10:01.124Z: OsProductName: Windows Server 2012 R2 Standard
2019-01-02T14:10:01.124Z: OsBuildLabEx: 9600.19202.amd64fre.winblue_ltsb.181110-0600
2019-01-02T14:10:01.124Z: Language: en-US
2019-01-02T14:10:01.139Z: TimeZone: Coordinated Universal Time
2019-01-02T14:10:01.139Z: Offset: UTC 00:00:00
2019-01-02T14:10:01.139Z: EC2 Agent: Ec2Config service v4.9.3160
2019-01-02T14:10:01.155Z: AWS VSS Version: 1.1
2019-01-02T14:10:31.701Z: Reading C:\Program Files\Amazon\Ec2ConfigService\Settings\config.xml
2019-01-02T14:10:31.795Z: EC2AddRoute: Failed to find local area connection
2019-01-02T14:10:35.826Z: EC2AddRoute: Failed to find local area connection
2019-01-02T14:10:39.873Z: EC2AddRoute: Failed to find local area connection
2019-01-02T14:10:43.904Z: EC2AddRoute: Failed to find local area connection
2019-01-02T14:10:47.935Z: EC2AddRoute: Failed to find local area connection

I have tried all that:
https://aws.amazon.com/windows/products/ec2/server2012r2/network-drivers/
https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/pvdrivers-troubleshooting.html#server2012R2-instance-unavailable
https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/common-messages.html#metadata-unavailable

But I still have the same problem.

Could someone help me please?

asked 4 years ago57 views
1 Answer
0

Solved adding an additional ENI.

answered 4 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions