View/modify amplify CLI published apps in the AWS console?

0

Hi there,

I've created an app with amplify init, amplify add storage, amplify add storage, amplify add hosting, etc., using the CLI.

Now I want to add a custom domain, but the app doesn't show up in the Amplify console.

What's the best way forward? Do I need to tear down the site and publish from a repo (e.g. git) via the Amplify console? Is there a way to perform custom domain configuration via the cli?

I've scoured the docs and Googled, but couldn't seem to find a good lead.

Any advice would be appreciated.

Thanks,

Kim

Edited by: kimford on Jun 26, 2019 3:04 AM

Edited by: kimford on Jun 26, 2019 3:04 AM

Edited by: kimford on Jun 26, 2019 3:05 AM

kimford
asked 3 years ago49 views
4 Answers
0

Hi,

Sorry for the confusion.
Init a project with amplify CLI will not create a AWS Amplify Console. What I would recommend is that push your project to GitHub and Connect your project to AWS Amplify Console. You will be able to set custom domain in AWS Amplify console.

Thanks,
Gary

answered 3 years ago
0

Hi Gary,

Thanks for the quick reply.

I'm gonna add some more info here, in case anyone come across the same issue and could use the help.

In short, I backed out of the cli hosting by using "amplify remove hosting". I then followed that up with a amplify push, which (I hope) removed all of the cloud elements. In fact, it did not remove the s3 hosing bucket, so I removed that manually.

That done, I used the AWS Amplify Console to connect a Bit Bucket repo with my app code.

On the first build attempt, it failed, as it could not find the src/aws-exports.js file, which was added to the .gitignore file automatically at some point during the setup of the site.

That particular file has what seems to be a lot of sensitive information, so I was hesitant to exclude it from .gitignore.

Tired and bored, and knowing that my bb-repo was private, I added and committed the file and waited.... and viola!

Publishing this way allowed me to add a custom domain.

If anyone has a better way, le me no....

kimford
answered 3 years ago
0

@kimford. You do not need to commit the exports file. This tutorial shows you how to deploy a fullstack Amplify app: https://docs.aws.amazon.com/amplify/latest/userguide/deploy-backend.html

answered 3 years ago
0

I have the same problem right now.
I build an Angular (Ionic) app with amplify.
When i first deployed the app with the amplify console everything worked fine.
Then my API-Key expired after 7 days. Now, after creating a new API-Key and setting the "APIKeyExpirationEpoch" = "-1" in parameters.json my app throws an error that the API-Key could not be found.

I already deleted my app from the amplify console and creating a new one like in the the link @nikhil1986 posted but still the same problem.
Removing the aws-exports.js from my gitignore solves the problem. But that can't be the long term solution right?

Maybe someone else already solved the problem and can help me?

Thanks so much
Jan

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions