[UE4] Fleet Error, instance Cannot Load Gamelift DLL


Hello everyone, I am trying to create a fleet for my unreal engine 4.19 build. I have set up the install.bat for installing dxwebsetup.exe and vc_redist.x64 (vs2017) while uploading to Gamelift. However, my dedicated server keeps crashing. So I remoted the fleet instance to see what is going wrong.

The problem was solved after I put those gamelift .dll into the folder C:\Windows\System32, which are

aws-cpp-sdk-gamelift-server.dll aws-cpp-sdk-cognito-identity.dll aws-cpp-sdk-core.dll aws-cpp-sdk-gamelift.dll

But that should not be solved by manually I guess, what should I do in order to solve this problem correctly? Anyways for helping the executable (game server) find out the .dll?

Also, it still got another error "A process unrecognized by GameLift is attempting to make GameLift Server SDK API calls. Are you using a process launcher?" How can I fix it? Is it because I was remote accessing the instance and running the executables?



asked 5 years ago58 views
2 Answers

Thanks for your answer @REDACTEDUSER

  1. In terms of the .dll files, I did put them into the "Plugin/GameLiftServerSDK" and "Plugin/GameLiftClientSDK", like this


According to your kind advice, I tried to put all the .dll files into "Plugin/GameLiftServerSDK" folder but it still didn't work. So I tried to put them into other folders to see if it will work fine. It works when the .dll files are placed in "Binaries\Win64" folder where is the loacation of the executable. Will it be fine by fixing it in this way? Or is there any other solutions?


  1. The executable path was set to "C:\game\GameL\Binaries\Win64\GameLServer-Win64-Shipping.exe" already. I am not sure why this is a problem, but it will stop popping up the error message in the event log if I close the executable which is launched by myself while remote accessing the instance. I just recreated a new fleet, and it works fine since I didn't manually run the executable until now.

So will it be a problem if I fixing the .dll files like this?


answered 5 years ago


  1. Regarding your .dll files--you have to place them inside the GameLiftServerSDK folder, which must take place within your project's Plugin/ folder. This way it'll be compiled along with the rest of your project. A common mistake is to place the GameLiftServerSDK plug-in in the UE4's folder. If you need further clarification on this subject, please refer to the official integration guide. I'm using 4.18 here and we could successfully integrate the plug-in--I doubt the process would be different on 4.19.

  2. "A process unrecognized by GameLift is attempting to make GameLift Server SDK API calls. Are you using a process launcher?" means that the GameLift instance is running the 'shortcut' of the binary of your GameServer.exe. Not sure why this is a problem, but as a solution, you could change the executable path to something like C:/game/Binaries/Win64/YourGameServer.exe rather than C:/game/YourGameServer.exe. It's important to note that this change requires you to recreate the fleet.

Hope this helps.

Best regards, Guilherme.

answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions