By using AWS re:Post, you agree to the Terms of Use

Error Msg: "This XML file does not appear to have any style information.."

0

Has anyone had people get this error message when they try to access a file from your S3 storage?

"This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code>AccessDenied<Code>"

If so, how do you fix it?

Thanks for any help!

Topics
asked 3 years ago2328 views
2 Answers
0

Hello

that is the "Access Denied" error message.
If you have access to the object, try downloading it instead of using the url link.

if the object is public or the entire bucket is public, that error will go away BUT everyone would be able to see the object.
https://aws.amazon.com/premiumsupport/knowledge-center/s3-access-denied-error/

hope this helps,
RT

answered 3 years ago
0

I don't know if i should keep searching or post my own new question. I'm having the same problem. I fount it happening only after some successful use and functioning of my app into S3 simple hosting. I had completed a course on AWS Serverless APIs and Apps. The app worked fine through much testing on my locahost. Then I deployed it to S3, distributed it on CloudFront, and connected a domain I own to Route 53 after requesting validation through the Certificate Manager. I do have some questions about the permissions and policies since my course instructor's S3 management interface was completely different than what I see today. For that reason, I'm not certain that those are properly set.

That being said, while testing the app, all menu links worked as expected, but I discovered that if I was on a child page and refreshed the browser I suddenly got the AccessDenied error message with the "This XML file does not appear to have any style information associated with it" statement. This happens regardless of the browser I try.

I followed the suggestion of downloading an object from the S3 bucket. i did so with no access problem, using the same credentials I used in creating the bucket. Was that supposed to fix this? So, I do have access. That doesn't seem to be the problem. I even unblocked all permissions and made the bucket public to see if that made a difference. It didn't.

Does anyone have some idea what I can do next?

answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions