- Newest
- Most votes
- Most comments
The error message means that AWS has blocked everyone, including you as an authorised user, access to the entire S3 bucket. It could happen because of many reasons, such as a security breach or unpaid bills. You should have received an email notification at your root (and security contact, for security incidents) email addresses, and you may also find the notification and instructions in the personal health dashboard in the account.
The error message is documented in this documentation section, with instructions to contact AWS support: https://docs.aws.amazon.com/AmazonS3/latest/API/ErrorResponses.html#ErrorCodeList
I have reached out to AWS support (Billing support), hopefully they will be able to delete the bucket.
There are no billing issues, nor I can find any relevant notification for this bucket.
Are you getting an error for a specific S3 bucket? In that case, the S3 bucket has been deleted but the DNS record or CloudFront distribution still points to it.
According to metrics (storage lens dashboard, bucket has 150GB of data. It was private all the time, so there are no "linked" resources such as Cloudfront distribution.
Relevant content
asked 2 years ago
- AWS OFFICIALUpdated 10 months ago

I have reached out to AWS support (Billing support), ticket 176245185900490, hoping they will be able to delete the bucket. Unfortunately, I haven't received a single response from AWS support for almost a month. Basically, I'm paying for something that I cannot access nor delete, and AWS is not responding. Pretty much stuck with AWS good will (or lack of it) to provide any details and/or resolution.