By using AWS re:Post, you agree to the Terms of Use
/Failing to connect to Chrome within Docker container on Lambda/

Failing to connect to Chrome within Docker container on Lambda

0

We are trying to launch and connect to an instance of Google Chrome within a custom Docker container Lambda runtime. It runs locally 100% fine using Runtime Interface Emulator.

We think it may be due to a difference in the Docker config when running it on Lambda compared to locally, preventing our runtime from accessing localhost. We've tried many different suggestions instead of localhost and also tweaked the network settings on the Docker image, but with no luck.

Code: https://bitbucket.org/rapidspike/workspace/snippets/KMMa9B

On line 37 remoteInterface() can also take a host as well as a port, but it defaults to localhost. We have tried 0.0.0.0, http://host.docker.internal and a bunch of other suggestions including using Lambda's env variables to get the IP of container at runtime.

Has anyone had similar problems or know of anything we should look into?

1 Answers
0

When you use a container image to package your lambda, the container is used only for packaging. It still runs the lambda like it would if your lambda was packaged as a zip file.

Having said that, I am not sure if this is going to be helpful, but there is an example of a browser from a lambda here - https://acloudguru.com/blog/engineering/serverless-browser-automation-with-aws-lambda-and-puppeteer

answered 20 days ago
  • Thank you Indranil, we will have a look into your suggestion

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions