Cloud9 debugger setBreakpoint error

0

Hi,

I am trying to debug a python file on cloud9. However i got the following setBreakpoint error


[IKP3db-g] 22:21:38,811879 - INFO - IKP3db 1.4.1 - Inouk Python Debugger for CPython 3.6+
[IKP3db-g] 22:21:38,814775 - INFO - IKP3db listening on 127.0.0.1:15471
[IKP3db-g] 22:21:39,086305 - INFO - Connected with 127.0.0.1:56936
[IKP3db-g] 22:21:39,231887 - ERROR - setBreakpoint error: Line /.aws/config.py:3 does not exist.

any suggestion will be appreciated

Nigel
asked 9 months ago217 views
1 Answer
0

I tried doing this with a sample python script and it worked for me. I just had to first make sure that I have saved the code file, and second I have selected the "Run in Debug Mode".

Sample script I used

string1 = "Linux"
string2 = "Hint"
joined_string = string1 + string2
print(joined_string)

Refer screenshot highlighting this and showing the debug is working. sample

Try using this simple script to check if debug function is working fine. If it doesn't then it could mean some issue and needs further investigation.

profile pictureAWS
EXPERT
answered 9 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions