Timeout when performing an "INSERT" query into RDS Aurora DB?

0

I have a Python Lambda function that accesses my RDS Aurora DB, copies a table, but doing the folllowing

conn = pymysql.connect(...)  
with conn.cursor() as cur:  
        cur.execute("create table some_table_temp like some_table;")  
        cur.execute("insert into some_table_temp select * from some_table;")  
          

I performed the following query into my sandbox RDS Aurora DB, and it worked. I then setup my Lambda function to use my staging environment (VPC, subnet, security groups). I'm getting a connection object, and am able to create the some_table_temp table, but the succeeding "insert" query fails due to timeout since this table takes longer than 3.00s to copy in the staging environment.

2020-10-17T17:14:15.243Z 17d05521-d0da-441c-bd71-befa37e447cb Task timed out after 3.00 seconds  

How can I increase the timeout for my DB queries?

Thanks.

ChrisFZ
asked 2 years ago102 views
1 Answer
1

It was the Lambda function timeout setting, which was 3.00s by default. Once I increased that, the function worked.

ChrisFZ
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions