By using AWS re:Post, you agree to the Terms of Use

The AWS Access Key Id you provided does not exist in our records.

0

Hi,

I'm trying to use terraform on AWS but I always get this error I have tried connecting with the access key and secret key through CLI but still the same error. I have tried making new keys and changing them but whatever I do I still get the same error.

1 Answer
0
  • checked it already it doesnt work for me I cant even connect through cli even if i put new access key and secret key

  • Have you checked that the user has the necessary permissions to carry out the commands that you tried from the CLI? For example if you tried aws s3 ls command, you need to ensure that the user has the necessary S3 permissions. Otherwise what you are saying does not make much sense. Try creating a Cloud9 and try running the CLI from inside Cloud9 by creating a different user than the one that created the Cloud9 environment and setting this new user's profile in Cloud9.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions