By using AWS re:Post, you agree to the Terms of Use

AWS Glue ERROR. Internal service error: Invalid Input Provided

2

I try to run a simple script (like: print('test')) in a glue job, but get next error: JobName:XXX and JobRunId:YYY failed to execute with exception Internal service error: Invalid Input Provided. Even yesterday afternoon, complex scripts worked without problems, but today such a simple script cannot work (Execution time: 0 seconds). All these problems are related to the Ireland region, for example, when script is executed in Virginia, such error does not occur.

  • can you share some more job details and whats in the log? Do you see InvalidInputException in your logs? Is the job a Spark or Python Glue job?

  • In the log I also see: failed to execute with exception Task allocated capacity exceeded limit. (Service: AWSGlueJobExecutor; Status Code: 400; Error Code: InvalidInputException; Request ID: XXX; Proxy: null). This job is a Spark job.

  • I have the exact same error in the Ireland region (eu-west-1).

    In my case I am using an AWS Lake Formation Blueprint which creates a Workflow and some Jobs in AWS Glue. I have run it multiple times and the workflow always fails with this error.

No Answers

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions