InitSDK timeout using GameLift SDK 5



I'm using Unreal Engine 5.1 with Gamelift sdk version 5.0.2 and uploaded the build to EC2 Managed, but the fleet is not starting with the error "SERVER_PROCESS_SDK_INITIALIZATION_TIMEOUT".

I defined all FServerParameters values as nullptr in InitSDK.

So I tried to connect with RDP to check the environment variables of ec2, but I tried to check the RDP connection information using the existing GetInstanceAccess, but that function seems to be unavailable after Gamelift 5.0.0. So I tried to access it using GetComputeAccess in the error message, but I can't access it because it only shows the token information, not the RDP connection information. I would be grateful if you can tell me how to access RDP.

Other than that, I was able to connect to the server from my personal desktop via Gamelift Anywhere.

Thank you.

1 Answer
Accepted Answer

Share the corresponding issue resolution. After the unreal server build, upload the build by including "libcrypto-3-x64.dll", "libssl-3-x64.dll" in the GameLift_UE5\Binaries\Win64 folder to activate the fleet normally. The file exists in the folder that was installed when openssl was installed.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions