NICE DCV fps settings

0

I currently have a setup where I run NICE DCV in a docker container and stream an application to a webpage using the webclient SDK. Unfortunately, the fps on the stream seems to somehow be limited to 30 fps, however, despite setting the targetFps in the dcv.conf file to 60. The grabber-target-fps settings is set to 0.

We use a g4dn.xlarge EC2 instance with Nvidia grid 14.3 drivers. The docker container is an ubuntu container.

How can I increase the fps?

asked a year ago325 views
2 Answers
0

The target FPS can be set on Linux in the display section of dcv.conf:

[display]
target-fps=60

Maybe you can show the relevant lines of your dcv.conf to verify?

answered a year ago
  • Here's my display section of the dcv.conf

    enable-client-resize=true
    
    enable-qu=true
    
    grabber-target-fps=0
    
    max-compressor-threads=4
    
    max-head-resolution=(4096, 2160)
    
    min-head-resolution=(426, 240)
    
    target-fps=60
    
    web-client-max-head-resolution=(0, 0)
    
    
0

Looking good. Related to the DCV Web SDK - if the user is on a recent Edge or Chrome version using the latest web client SDK, they will be able to have 60 FPS (no setting needed). Which browser are you using?

answered a year ago
  • It doesn't matter which browser we use. Neither Client, nor integrated web server and the web sdk can get more than 30 fps.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions