RDS for PostgreSQLのメジャーバージョンアップが失敗する

0

RDS for PostgreSQLのバージョン11.22をコンソールの変更からアップグレードを試みています。 バージョン12.17、13.13、16.1へのアップグレードを試しましたが、失敗しました。 イベントのシステムノートは以下の通りです。

Database instance is in a state that cannot be upgraded: Postgres cluster is in a state where pg_upgrade can not be completed successfully.

対応策をご教示ください。

クラス:db.t3.micro 空き容量:20GB シングルAZ ストレージタイプ:汎用 SSD (gp2)

asked 3 months ago341 views
2 Answers
0
Accepted Answer

ログを見落としており、ログの再確認で解消できたので、 備忘録として内容記載します。

pg_upgrade_internal.logに下記が出力されていました。

fatal
Your installation contains tables declared WITH OIDS, which is not supported
anymore. Consider removing the oid column using
    ALTER TABLE ... SET WITHOUT OIDS;
A list of tables with the problem is in the file:
    tables_with_oids.txt

下記を参考に、OIDを削除することでバージョン12.17へのアップグレードに成功しました。 https://dba.stackexchange.com/questions/259359/eliminating-oids-while-upgrading-postgresql-from-9-4-to-12

answered 3 months ago
0

Stackoverflowの回答にあるようにコマンドもしくはコンソールで詳細なログを確認する必要があります。
https://stackoverflow.com/a/70805896
https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/USER_LogAccess.Procedural.Viewing.html

アップグレード方法は以下のブログが参考になると思います。
https://www.cloudbuilders.jp/articles/2276/

profile picture
EXPERT
answered 3 months ago
  • 回答ありがとうございます。 ログを再確認したところ、原因解明出来ました。

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions