By using AWS re:Post, you agree to the Terms of Use
/Server time out/

Server time out

0

I am trying to run a "dotnet build" from within my t2.micro server, It just hangs and never executes. What could be the issue? I have added volume to the instance, but no improvement

  • We would need some more information to help. Which AMI do you use? What is your EC2 instance configuration (instance store or EBS, volume size, networking, ...) Which .NET SDK do you use? What kind of project do you build? Does it require NuGet packages? Have you tried to check with top how much CPU and memory the .NET SDK uses? In general, it should work. For troubleshooting your issue you'd have to identify what is causing the freeze (network, storage, CPU, ...)

asked 3 months ago6 views
1 Answers
0

Hi, @Chisco-Iris

I tried to build with EC2 instance size set to t2.micro, but it didn't hang.

[root@ip-10-0-20-225 hoge]# dotnet build --diagnostics
Microsoft (R) Build Engine version 17.1.1+a02f73656 for .NET
Copyright (C) Microsoft Corporation. All rights reserved.

  Determining projects to restore...
  All projects are up-to-date for restore.
  hoge -> /usr/bin/hoge/bin/Debug/net6.0/hoge.dll

Build succeeded.
    0 Warning(s)
    0 Error(s)

Time Elapsed 00:00:01.53
  • Does it work properly if I change the instance size?
  • Get additional information by adding some options during dotnet build.
  • Does it work for dotnet restore?
EXPERT
answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions