By using AWS re:Post, you agree to the Terms of Use

AWS SAM CLI Error: Error: PythonPipBuilder:ResolveDependencies - {pyyaml==6.0(wheel)}

0

Hi, I am keeping running into the same error as mentioned in the title even though I have installed wheel. I have tried sam build --use-container (and there is a template.yaml in the folder), but it caused another error (Error: Docker is unreachable. Docker needs to be running to build inside a container).

It would be appreciated if there is anyone who could help me for solving this issue!

1 Answer
2
Accepted Answer

Do you have docker installed and the docker daemon running on the machine from where you are trying to use sam build --use-container command.

Take a look at https://docs.aws.amazon.com/serverless-application-model/latest/developerguide/serverless-sam-cli-install-windows.html

Step 3 - Install Docker mentions the following - "Docker is a prerequisite only for testing your application locally and for building deployment packages using the --use-container option. If you don't plan to use these features initially, you can skip this section or install Docker at a later time."

So if you are using the --use-container option, then you do need docker to be running on the machine.

profile picture
EXPERT
answered 15 days ago
  • It worked. Thank you so much :)

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions