COPY ignoring extra columns

0

I recently noticed that Redshift COPY command is ignoring any extra columns at the end of the source file which are missing in the table being loaded. I remember copy command used to fail with Extra columns found error earlier. Is this a new behavior recently released?

asked 8 months ago736 views
1 Answer
0

Hello,

As per https://docs.aws.amazon.com/redshift/latest/dg/r_COPY.html , there has been no change to COPY command recently.

If you use COPY command with "maxerror" parameter then it will ignore the records with additional columns.

https://docs.aws.amazon.com/redshift/latest/dg/copy-parameters-data-load.html#copy-maxerror

Thank You !

answered 8 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions