Bedrock Batch Inference with Claude

0

Hi,

I have been using bedrock batch inference for a while, despite being in preview it seems to typically work most of the time. However I have recently tried using batch inference with Claude 3 in the eu-west-2 region and I am getting the following error:

botocore.errorfactory.ValidationException: An error occurred (ValidationException) when calling the CreateModelInvocationJob operation: The provided request is not valid

Unfortunately it doesn't tell me which part of the request is not valid. When making the exact same request to Claude 3 in the eu-west-3 and us-east-1 region it works perfectly still. I am also getting the same error when calling batch inference on Claude3.5 in the us-east-1 region.

Are some models disabled for batch inference? Or has there been an API update that hasn't been rolled out across all regions? Is anyone else able to get Bedrock Batch Inference working with Claude 3 in eu-west-2 or Claude 3.5 in us-east-1?

Any help would be great.

  • I'm having the same issue. It is specifically Claude 3.5 for batch inference. 3.0 works and 3.5 works for non-batched inference.

profile picture
asked 4 days ago84 views
1 Answer
0

Hi,

This table may be useful to you to check the availability of the various Bedrock models in the different regions that you are interested in: https://docs.aws.amazon.com/bedrock/latest/userguide/models-regions.html

Best,

Didier

profile pictureAWS
EXPERT
answered 4 days ago
profile picture
EXPERT
reviewed 4 days ago
  • This doesn't seem to have an entry for Claude 3.5 Sonnet

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions