Managed Blockchain, HTTP Endpoint will not start working

0

Hello, I just bought €300/month service from you, and my Ethereum Node HTTP Endpoint will not even start working!!

Following tutorial: https://docs.aws.amazon.com/managed-blockchain/latest/ethereum-dev/json-rpc-api-examples.html#json-rpc-api-tba-examples

I have endpoint example: https://your-node-id-lowercase.t.ethereum.managedblockchain.us-east-1.amazonaws.com?billingtoken=your-billing-token

I will that with my token and node... and it says {"message":"Missing Authentication Token"}.

Could you please tell me how to make this work using access token? And not that Signature 4 and etc complication..

EtherX
asked 6 months ago766 views
2 Answers
0
Accepted Answer

I've fixed it... It seems only AWS in whole web3 has two endpoints for the same node... one is for the SIG4, and one for the access token. It was not clear, I copied the endpoint from my dashboard what I saw, but it was missing letter "t".. very hard to see!

https://your-node-id-lowercase.t.ethereum.managedblockchain

Notice ".t" letter... SIG4 is without letter t.. It was not clear written.. btw already deleted it, very poor performance..

EtherX
answered 6 months ago
  • I am glad you were able to solve your issue!

    May I ask what instance type were you using for your node? Also, what performance issues were you encountering?

    Please let me know if you have any more questions.

  • I've tested with instance 16GB RAM which was offered.. and was just made test request to method eth_getBalance, it was like 600ms... I created this to have a performance, and wanted this under 100ms, and also thought I can create private connection to node, and have a result in like 3-4ms.. It will be good to also add archieve node, and VPC to it, so users can retrieve data in under 4ms.. instead of 600ms.. Usually I've created it to have a performance, otherwise, I do not find it useful..

0

Hello!

Out of curiously, what command did you run when you received this error message? If you were sending your request with "awscurl", make sure that you have set your credentials (secret and access keys). You can do this by running the command aws configure.

I am not sure if you have resolved this error yet, but make sure that you are using the "Token" parameter for "your-billing-token", rather than the "Accessor ID". I have attached a screenshot for reference. Also make sure that the region is correct in your endpoint -- this should be the region that your Managed Blockchain Ethereum node is hosted in.

Can you run the following command from your terminal and see if it returns a valid response? Make sure that you adjust the parameters for "your-node-id-lowercase", "region", and "your-billing-token" accordingly.

If you get an error message, please let me know and I will help you further troubleshoot.

curl -X POST -d '{"jsonrpc":"2.0","method":"eth_blockNumber","params":[],"id": 1}' 'https://your-node-id-lowercase.t.ethereum.managedblockchain.us-east-1.amazonaws.com?billingtoken=your-billing-token'

I hope this helps -- please let me know if you have any more questions. Have a great rest of your day!

Enter image description here

profile pictureAWS
EXPERT
answered 6 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions