- Newest
- Most votes
- Most comments
It was because AWS enforce only one forwarding rule per domain name can be associated with a VPC at a time.
Would suggest trying to fix by the following:
- Manually disassociate the existing conflicting rule from the VPC.
- Then associate the profile, which will allow the new rule to be applied. Alternatively, if you want to retain the existing rule, you can:
Exclude the conflicting rule from the profile when associating it with that specific VPC.
Hey,
Hope you're keeping well.
Route 53 Resolver enforces a hard limit of one forwarding rule per domain name per VPC, so if a VPC already has a rule for example.com from Account X, the association from your profile will fail for that specific rule. During a profile rollout, AWS will skip applying rules where a conflict exists, but the rest of the non-conflicting rules in the profile will still be associated successfully. If you need the profile’s rule to take precedence, you must first disassociate the existing rule from the VPC, then re-run the profile association. Alternatively, you can remove the conflicting rule from the profile for affected VPCs if you want to keep the current setup.
Thanks and regards,
Taz
answered 9 months ago
Relevant content
asked 5 months ago
- AWS OFFICIALUpdated 2 years ago

Thanks a lot. But will association of profile fail or profile will be associated with all settings and other rules that are not conflicting ? Second question. Let's assume different scenario. I'm associating profile with all VPCs without any rule (only with interface endpoints). And later on I will add rule that maybe in conflict with some other associated with VPCs. What will happen ?