By using AWS re:Post, you agree to the Terms of Use
/Increasing the idle timeout in Load Balancer is not being reflected/

Increasing the idle timeout in Load Balancer is not being reflected

0

Hello.

One of my environments is using a Classic Load Balancer. Sometimes, the queries I run in our database take more than just one minute, so I needed to increase the idle timeout of the Load Balancer (which is one minute by default). We followed the instructions and changed it to 3600 (s). However, I'm still getting the "connection closed" message after just one minute, so the new value of the idle timeout seems to have no consequence. Is there anything else I should be doing?

1 Answers
0

Hi,

I understand that you have increased the idle timeout on your Classic Load Balancer but you are still getting the connection closed error. Please feel free to correct me if my understanding is wrong.

I recommend that you enable the HTTP keep-alive option for your instance. Keep-alive enables the load balancer to reuse back-end connections until the keep-alive timeout expires. This is to ensure that the load balancer is responsible for closing the connection to your instance, make sure that the value you set for the HTTP keep-alive time is greater than the idle timeout setting configured for your load balancer. For more information on how to configure the idle timeout on the console or on your AWS CLI click on the link below[1].

References:

[1]https://docs.aws.amazon.com/elasticloadbalancing/latest/classic/ts-elb-error-message.html#ts-elb-errorcodes-http504

I hope you find this information useful.

answered 12 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions