By using AWS re:Post, you agree to the Terms of Use
/opensearch cross-cluster replication stuck in 'BOOTSTRAPPING' state/

opensearch cross-cluster replication stuck in 'BOOTSTRAPPING' state

0

I’m having trouble setting up multi-region replication between two aws opensearch domains. I’ve been following the documentation (https://docs.aws.amazon.com/opensearch-service/latest/developerguide/replication.html) but once I start the replication via PUT call and query the replication status I see that the status is stuck at ‘BOOTSTRAPPING’ and I can see that no bytes have been transferred, even hours later.

PUT request payload to start the replication:

{
  "leader_alias": "dss-pre-prod-use2-usw2",
  "leader_index": "devportal.resourcev2",
  "use_roles":{
    "leader_cluster_role": "all_access",
    "follower_cluster_role": "all_access"
  }
}

GET response:

{
  "status": "BOOTSTRAPPING",
  "reason": "User initiated",
  "leader_alias": "dss-pre-prod-use2-usw2",
  "leader_index": "devportal.resourcev2",
  "follower_index": "devportal.resourcev2",
  "bootstrap_details": {
    "bytes_total": 0,
    "bytes_recovered": 0,
    "bytes_percent": 0.0,
    "files_total": 0,
    "files_recovered": 0,
    "files_percent": 0.0,
    "start_time": 1650317767399,
    "running_time": 18585600
  }
}

There are only 5 documents in the leader index, so the replication seems stuck. I've tried deleting the follower index and restarting the replication multiple times but with the same result. How can I debug this issue?

asked a month ago9 views
1 Answers
0

Hi , hope this situation has been resolved by now.

for the next time , or otherwise if you still have the issue. This is a case in which AWS Support should be able to help you, because no general answer may apply and something contextual to your account might be causing the issue.

Your best next steps would be to open a Support case, in case you have not yet a Support subscription, consider to upgrade to Developer Support or Business support depending on the urgency of your case.

Without looking at the internal logs or having more detailed information on the situation it is not possible to provide guidance, sorry.

hope this helps

SUPPORT ENGINEER
answered 23 days ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions