By using AWS re:Post, you agree to the Terms of Use

Running R on AWS troubleshooting.

0

I have tried following the instructions herehttps://aws.amazon.com/blogs/big-data/running-r-on-aws/ to set up RStudio Server on AWS, but I can't connect to RStudio in my browser (Firefox says it is "unable to connect"). Strangely, I can connect to shiny server, although the shiny apps don't load.

One specific question I have is why are the lines
rm rstudio-server-rhel-1.0.153-x86_64.rpm
and
rm shiny-server-1.5.4.869-rh5-x86_64.rpm
included in the install script? Doesn't this remove the packages?

I've tried troubleshooting this for a while, but haven't made any progress. Any suggestions would be appreciated!

asked a year ago51 views
1 Answer
0

Figured it out.

rm lines were to remove package installers only. Needed to use "sudo amazon-linux-extras install R4" instead of "yum install -y R". To properly install R on the new AMIs.

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions