S3 buckets without region


Somehow the following S3 buckets were created in the AWS account without a region and we cannot delete them or view them


We can also see them on the CLI doing

aws s3 ls

but trying to delete them we get the following

aws s3 rb s3://manccs-sanda-xxxxxxxx
remove_bucket failed: s3://manccs-sanda-xxxxxxxx An error occurred (NoSuchBucket) when calling the DeleteBucket operation: The specified bucket does not exist

Doing this as Account admin and have even tried using the root user but same result. How do we get rid of these buckets ?

Note same issue as this but no answer

1 Answer

Hi There

Have the buckets been deleted already? See this KB article that might explain the behavior


profile picture
answered 18 days ago
  • thanks for the reply ... i have seen that but I would not except the buckets to still be showing in the GUI after been deleted a few hours ago. A few minutes or so sure but would have expected them to be gone by now ... or am i mistake and I just need to give it more time ?

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions