CloudWatch dashboards suddenly show no data


My CloudWatch dashboards were all showing data for the past week. I copied a couple of panels on my CloudWatch dashboard, then saved the dashboard to another name.

Now, no panel in either dashboard is showing any data. I've tried selecting time period of 15m, 1h, 3h, 1w, 1 month. The charts simply don't show any data points. The tables show, "No data found. Try adjusting the dashboard time range or log query."

One of the queries, which I did not edit today is:

filter(eventName="GitPush") | stats count() as GitPushRequests by bin (5m) as t | sort t asc

We definitely have GitPush events in the past week. Usually dozens or 100s per minute.

I tried logging out and back in. I am in Chrome. I even tried going to the dashboard from Firefox, first time accessing from that browser, in case it was a browser caching issue. (I don't want to clear browser cache if I don't have to.)

Also note that I tried editing a couple of the panels to bring me to "Logs Insights" with the Save changes button. From there, I run the query and it does show data. So, the issue is with the dashboard, not the data, not the queries.

Edited by: Marnee on Feb 2, 2021 12:30 PM

asked 3 years ago2295 views
1 Answer

I edited my original question to say that I tried editing one of the panels and running the query from the edit panel screen.

After doing that, I cancelled the edit. When it went back to the dashboard, now data is showing. This looks like a defect to me.

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions