setting connection between aws glue and mongodb atlas

0

i got a mongodb atlas cluster outside aws. I want to use aws glue with my mongo db databases so i created a connection but im getting "InvalidInputException: Unable to resolve any valid connection". Im sure that i provide a valid URL and username and password.

Then I found this article (https://aws.amazon.com/es/blogs/apn/connecting-applications-securely-to-a-mongodb-atlas-data-plane-with-aws-privatelink/) to configure a private link between aws and atlas but there is an associated cost for both services

There is another way?

ignacio
asked 2 months ago102 views
1 Answer
0

Hello,

As you may know already, MongoDB atlas requires an additional "+srv" thing in the connection URL, could you please check if you have included "+srv" in the URL.

MongoDB Atlas URL need to be provided in the format: mongodb+srv://mongoHost:mongoPort/mongoDBname.

You can also go through below AWS documentation to verify if you are missing any steps or configuration.

[1] MongoDB connections - https://docs.aws.amazon.com/glue/latest/dg/aws-glue-programming-etl-connect-mongodb-home.html

[2] Testing an AWS Glue connection - https://docs.aws.amazon.com/glue/latest/dg/console-test-connections.html

You can also refer below documentations to understand different deployment options.

https://aws-ia.github.io/cfn-ps-mongodb-atlas/#_deployment_options

https://aws.amazon.com/blogs/big-data/introducing-mongodb-atlas-metadata-collection-with-aws-glue-crawlers

profile pictureAWS
SUPPORT ENGINEER
answered 2 months ago
  • Yes, my url is mongodb+srv://my-company.some-code.mongodb.net/db-name Where i get the url in this format? mongodb+srv://mongoHost:mongoPort/mongoDBname

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions