By using AWS re:Post, you agree to the Terms of Use

Local machine cannot access to aws MSK

0

I followed "public access" to set up the configuration. I have two goals, Firstly, I want to create topic from local terminal by using this command line "<path-to-your-kafka-installation>/bin/kafka-topics.sh --create --zookeeper ZookeeperConnectString --replication-factor 3 --partitions 1 --topic ExampleTopicName", but it always return "the broker is not available". Secondly, I want to connect MKS from local .Net Application. However, it seams cannot connect to the MKS successfully.

This is my some configuration that attach on my MKS

  1. Create public subnet 172.31.0.0/20 and 172.31.16.0/20 and attach an Internet Gateway
  2. Close unauthenticated access control off and turn on SASL/SCRAM access-control methods. Besides, I attached an secret for this authentication and add allow.everyone.if.no.acl.found to false to cluster's configuration.
  3. Turn on public access
  4. Cluster configuration Enter image description here
  5. Producer ConfigurationEnter image description here
  6. Security GroupEnter image description here

Does anyone can give me some advice or hints? I do some research that not sure I have to add listeners in my cluster configuration? Thanks for your time and consideration.

1 Answer
0

Hi , This seems to be a connection issue to your broker. Can you check the following:

  1. Your inbound security group should allow traffic (on port 9196) from the public ipv4 address of your local machine.
  2. Your client secret is associated with the cluster
  3. Your client has the necessary kafka-acl permissions to perform create topic operation

Hope this helps.

answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions