Add "insecure" to export options on NFS server.

0

Hello,

I am running into an issue mounting our NFS server on some osx devices, with the error can't mount /<name> from <ip> onto /Users/mac: Operation not permitted

Did some googling and one suggested solution was to add “insecure” to the export options on the NFS server side, located in the /etc/exports file on the server.

However, I seem to be unable to get into the files on the EC2 server we're hosting it on. It won't allow me to log in as root and admin just takes me to a management console for the storage gateway which doesn't have any of the normal commands. cd, sudo, ls, etc are all unavailable.

How can I get into the server to change this setting? Or if there's a better way to fix this issue, i'm all ears.

Thanks!

asked 5 years ago1528 views
2 Answers
0
Accepted Answer

Hi,

This looks like a permissions issue. Are you trying to mount the NFS share to a home directory? Try changing the mount point to an empty directory where you have write permissions. You may need to use "sudo".

Cheers,
JK

AWS
answered 5 years ago
0

Thank you, it was indeed a permissions issue. We were trying to mount the fileshare to ~

answered 5 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions