SQS not receiving SNS message

0

I have an SQS Endpoint configure in my SNS Topic.

The SQS Endpoint is in "Confirmed" status.

The SQS Queue has the correct permissions (Principals Everybody, Actions SQS:SendMessage, ForAnyValue:ArnEquals <mySNSTopicARN>)

I have even tried setting up from scratch, a new SNS and new SQS but that SQS does not receive the SNS messages either even though status is "confirmed" (I used the console Queue Actions -> Subscribe Queue to SNS Topic).

Help ?

asked 4 years ago913 views
1 Answer
0

I had the same problem and found the following long answer in this forum: https://forums.aws.amazon.com/thread.jspa?messageID=508239&#508239

What solved it for me was that you need to subscribe the SQS to the SNS topic from the SQS console

You select the SQS and in the top drop-down "Queue Action" select "Subscribe Queue to SNS topic". For some reason, this makes teh SQS starts to receive notifications, while doing teh subscription from the SNS side does not work.

answered 3 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions