AWS DNS not updating

0

I've also put this on StackOverflow which was my first instinct https://stackoverflow.com/questions/74975099/aws-dns-not-updating/74975409#74975409

I am attempting to configure the DNS records in Route53. As an experiment im trying to host a static website from an S3 bucket, use Cloudfront and attach a custom domain. This should not be a problem!!!!!!!

Thus far its a fail and i'm considering never going near AWS with a bargepole again, all the same I would like to see this through before I cancel my subscription.

CloudFront distribution is working securely at https://dr3uff0ffprrr.cloudfront.net/ although it is slower than expected.

I can't attach a custom domain to the CloudFront distribution with DNS routing. I know it can take 72 hours to propagate, I am way beyond that now. I have also tried the enhanced support option but all they do is refer to the literature which I could have read for myself at no extra cost.

The custom domain that I want to use is www.androit-solutions.com. Oddly it is hosted by AWS Route53 and I wonder if that has actually made it more complicated to use.

Anyway, a bucket has been created for domain and subdomain. My inputted DNS details are:

androit-solutions.com A Simple - dr3uff0ffprrr.cloudfront.net.

androit-solutions.com AAAA Simple - dr3uff0ffprrr.cloudfront.net.

androit-solutions.com NS Simple - ns-1581.awsdns-05.co.uk ns-115.awsdns-14.com ns-755.awsdns-30.net ns-1266.awsdns-30.org

androit-solutions.com SOA Simple - ns-1581.awsdns-05.co.uk. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400

www.androit-solutions.com A Simple - dr3uff0ffprrr.cloudfront.net.

www.androit-solutions.com AAAA Simple - dr3uff0ffprrr.cloudfront.net.

DNS server lookup sites report that there are no DNS records. Zone is definitely public.

Please help or feel free to suggest alternatives.

Thanks

Robert

Please see everything above

asked a year ago357 views
3 Answers
0

Right, positive things appear to be happening Two notifications have appeared:

androit-solutions.com Name server update successful 2023-01-01 22:41:51 androit-solutions.com Domain registration successful 2022-12-26 14:03:45

dns lookup is also looking good

I will give this some time to propagate but I would still appreciate it if you could check over the other infos that I have inputted. I came within the width of a ballhair away from ditching AWS, I suspect its something to do with the website GUI and it was incredibly annoying

answered a year ago
0

When you register a domain with Route 53, it automatically creates a hosted zone for that domain. But it seems that no hosted zone is currently associated with your domain androit-solutions.com as it is not possible to find any name server for this domain. Hence, if you created the public hosted zone that you are currently using separately, please consider updating the name servers in the below record for your domain.

androit-solutions.com NS Simple - ns-1581.awsdns-05.co.uk ns-115.awsdns-14.com ns-755.awsdns-30.net ns-1266.awsdns-30.org

Instruction on how to update the name servers for a registered domain is provided in the link below:

Adding or changing name servers or glue records

More details on replacing a hosted zone for a registered domain can be found here:

Replacing the hosted zone for a domain that is registered with Route 53

Hope this helps!

AWS
answered a year ago
  • I think I might be getting somewhere here...for some unknown and go awful reason I have only now received an Email saying that my name servers have been updated

  • pic1 pic2

    I have been updating from the GUI in pic2 and I never ever got an Email confirming the update until I tried the GUI in pic 1

    I was told to update SOA records by support, they gave me:

    ns-1581.awsdns-05.co.uk. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400

    I don't know if thats right im a bit suspicious

    Please let that be it that was so frustrating

0

I think you might be better served by using a CNAME to point to the cloudfront distribution.

Details below . . .

https://docs.aws.amazon.com/AmazonCloudFront/latest/DeveloperGuide/CNAMEs.html

Also check If your domain's NS records properly updated in Route53? https://docs.aws.amazon.com/Route53/latest/DeveloperGuide/migrate-dns-domain-in-use.html

Is your S3 bucket setup to host static websites? https://docs.aws.amazon.com/AmazonS3/latest/userguide/HostingWebsiteOnS3Setup.html

profile pictureAWS
answered a year ago
  • Thanks but i've been through the literature many times and its not up to date, many of the links it refers to are simply not there, something that support doesn't seem to understand. There are no DNS records for the domain they simply won't update. I have already tried the CNAME. S3 buckets are configured and working as is cloudfront.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions