Why can I not RDP into my Windows EC2


I created an EC2 on a t2.micro using the Windows_Server-2019-English-Full-Base-2021.11.10 AMI. I have an elastic IP setup with the instance as well. I went into the Connect section and downloaded the remote desktop file. In addition, I retrieved the password without issue using the associated key pair the instance was created with.

I have an inbound rule for port 3389 to allow all traffic.

I have tried including a '' in front of the username Administrator I have also tried copy and paste of the password along with typing in the password. Each time I get an error of login attempt failed.

Is there something I am missing that would prevent me from being able to RDP?

  • Hi - Can you check if you can do a telnet <elastic IP> 3389 port to see if you are able to access?

  • Hi, Try to telnet to the external IP of the windows instance on port 3389. Also please check your security group's inbound and outbound rules.

  • You can also check if the subnet is public and validate access in NACL. I think you can also analyze this problem using VPC Reachability Analyzer.

  • I am able to telnet with no issue.

asked 2 years ago1717 views
2 Answers

I use the format ".\Administrator" (be sure to include the period) when I want to authenticate as the local Administrator user of the instance. If that still doesn't work and you are familiar with the AWS SSM service, you could attempt to connect to the instance via the SSM Session Manager component, which would give you a PowerShell session. There, you can create a new local administrator account by issuing the following commands:

  1. net user <NEW_USER_NAME> <PASSWORD> /add
  2. net localgroup administrators <NEW_USER_NAME> /add

For more information about how to setup SSM Session Manager, please take a look at the following link https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager-getting-started.html

answered 2 years ago

Try using this format, internal ip\administrator (example\administrator) as the username.

Also it sounds like the networking is correct if you can telnet, but just for reference this is how public and private subnets work within your VPC: https://docs.aws.amazon.com/vpc/latest/userguide/VPC_Scenario2.html If you do not have a subnet with a proper route to an IGW you will not be able to RDP in from the internet. Make sure the Route table(s) are setup with the correct routes.

I assume the instance has been up for a while now, but also as an FYI a t2.micro Windows Server 2019 will take some time before it will be ready to receive inbound RDP connections after boot up.

profile pictureAWS
answered 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions