By using AWS re:Post, you agree to the Terms of Use

Failing to launch test/cutover instance with public IP

0

I have a migration job for a Windows machine that's failing to launch the test/cutover instance using the Application Migration Service and is spitting this out: Error: An error occurred (InvalidParameter) when calling the RunInstances operation: The AssociatePublicIpAddress parameter is only supported for VPC launches.

The destination subnet is a public one and is configured to assign public IPs on launch; manually launching an instance in the subnet does get assign an ephemeral public IP. Any help would be greatly appreciated.

asked 9 months ago270 views
2 Answers
0

I'm wondering if the subnet you're using is in a VPC that is in the legacy EC2-Classic and not EC2-VPC mode.

If your VPC is not in legacy EC2-Classic, are you using a default or non-default VPC?

More information: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/ec2-classic-platform.html

Also note when using Application Migration Service, the EC2 launch template does not automatically set a specific Subnet. Thus, if not specified, it will try to launch in a subnet as part of that default VPC. If the default VPC is removed, EC2 will fail to launch any instance if there's no valid subnet specified.

answered 9 months ago
  • Thanks jsonc. The Application Migration Services does have a public subnet specified in the template which is in a EC2-VPC, and a non-default VPC. In fact, there is no default VPC at all configured in the region I'm trying to migrate the machine, so it must have been removed at some point. I've also tried configured different public subnets from different VPCs in order to launch the test instance, but all fail with the same error code.

    I could probably try to re-create the default VPC and see how that works.

  • hello mrex - were you able to resolve this issue? I'm also getting the same error. Any suggestions? or steps you followed to resolve it?

0

I configured the specific network subnet in EC2 launch template settings and solved the issue.

answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions