Command 'dcv close-connection <sessionid> not working

0

I am trying to disconnect a single user from a dcv server session called 'dcvusersession'. I try to do this using the command dcv close-connection dcvusersession but to no avail. The server responds with: Error: no session ID specified. In general, anything I add after the close-connection command makes no difference. I tried the userId, the integer of the session Id but nothing worked. Is this a bug. Unfortunately this command is not documented in the online documentation here.

The used DCV Server Version is 2022.2.13907-1, I couldn't find anything in the release notes on that topic however.

Thanks and kind regards, Julian

asked 7 months ago231 views
1 Answer
0

Hi Julian,

can you show the session with (maybe you need to be root if not the same user)

dcv list-sessions

Are you trying to close the connection running the command as the same user owning the session or the root user?

Here is the docu: https://docs.aws.amazon.com/dcv/latest/adminguide/managing-sessions-lifecycle-stop.html

Best regards, Karsten

answered 7 months ago
  • It was my mistake, I ran dcv-close-session -h and found that my syntax was wrong. It now works. Thanks

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions