Error RTSP stream kinesis

0

Dear friends, I meet an issue to provide a RTSP video stream - I use a raspberry pi as producer. I don't use cert through Iot configuration. The video stream works if I use my webcam (/dev/video0) the gstreamer plug in seems working without issue. But each time that I want to stream through RTSP it doesn't work. I tried with the producer and with the docker image :

  • Producer via AWS_ACCESS_KEY_ID=xxxxxxxxxxxxxxxxx AWS_SECRET_ACCESS_KEY= ... gst_base_src_loop (): /GstPipeline:rtsp-kinesis-pipeline/GstRTSPSrc:source/GstUDPSrc:udpsrc0: streaming stopped, reason not-negotiated (-4)

  • Docker : gst_base_src_loop (): /GstPipeline:rtsp-kinesis-pipeline/GstRTSPSrc:source/GstUDPSrc:udpsrc0: streaming stopped, reason not-negotiated (-4)

  • Producer via gst-launch-1.0 -v rtspsrc location ... ERREUR : de l’élément /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc0 : Internal data stream error. Information de débogage supplémentaire : gstbasesrc.c(3055): gst_base_src_loop (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0/GstUDPSrc:udpsrc0: streaming stopped, reason not-negotiated (-4)

I use the same web camera that works in direct - means the rtsp source is the same camera supported by another raspberry used as RTSP server. The rtsp stream works in my local network and can be play from the raspberry used as producer and as docker host. I tried to change the AWS region (US and EU)but still the same issue. I tried to change some settings like storage-size or h264 settings like h264parse but without success.

Thanks in advance if you have some direction to troubleshoot or some advice's.

Kind regards,

1 Answer
0
Accepted Answer

Dear friends, In meantime I found the solution. It was about the codec used, I suspect a question about h264 settings. I tried v4l2rtspserver but without success. With gstreamer rtsp server it works from all configuration, means producer or docker. It works also with simple rtsp server (mediamtx).

Now I have some error about codec used like below follow navigator used to check the video stream : I use Edge, or Firefox or Chrome. like this : codec not supported avc1.7a001e (H.264 ???@3,0) or (H.264 ???@1.3).

Kind regards,

strapp
answered 2 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions