amazon-linux-extras install epel broken on ARM64 instances

0

I am trying to install epel using amazon-linux-extras on a t4g ARM64 instance:

sudo amazon-linux-extras install epel

This used to work until recently, but now results in the following error:

[ec2-user@ip-... ~]$ sudo amazon-linux-extras install epel -y
Installing epel-release
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
Cleaning repos: amzn2-core amzn2extra-docker amzn2extra-epel epel
3 metadata files removed
0 sqlite files removed
0 metadata files removed
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core                                                               | 3.7 kB  00:00:00
amzn2extra-docker                                                        | 3.0 kB  00:00:00
amzn2extra-epel                                                          | 3.0 kB  00:00:00


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
        or
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot retrieve metalink for repository: epel/aarch64. Please verify its path and try again
Installation failed. Check that you have permissions to install.
asked 10 months ago127 views
1 Answer
0

Greetings sergeiwoven,

I found the resolution of the issue you're experiencing. The EPEL repository is already installed on the original version of Amazon Linux, the only thing you need to do is enable it. By observing from the steps you provided in your post, you only installed EPEL but have not enabled it.

You can enable EPEL repository by using the yum-config-manager command or by editing the epel.repo file.

See command below to enable the EPEL repository:

sudo yum-config-manager --enable epel

To install EPEL repository on other Linux distributions please refer to this AWS Blog, which was last updated on 2021-11-17

I hope this helps.

Lunga
answered 5 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions