cli config command not working

1

I am using version 2 of the cli. trying to run the aws configure command, downloaded the csv file for a new user and get the error 'Expected header "User Name" not found. i finally got a csv download file that looks like its in the right format. but still no good. tried pointing at the download directory, still no good. The command looks like this:

aws configure import --csv C:\Users\system\Downloads\new_user_credentials-1.csv

  • On Window, don't use 'C:<path><csv_file>', instead use 'file://<path><csv_file>'. When I did, I didn't need the C: in the <path>

jamesxx
asked 3 years ago2512 views
2 Answers
2

The exported CSV from AWS Console did not include the User Name column.
The solution is to edit the CSV file and add the User Name column as follows:

User Name,Access key ID,Secret access key
yourUserName,yourKeyId,yourSecretAccessKey

Then run the command with the "file://" prefix to the file path.
You should expect to see the successful output.

$ aws configure import --csv file://your_credentials.csv
Successfully imported 1 profile(s)

Edited by: TinkererExtraordinaire on Feb 11, 2021 11:31 AM

answered 3 years ago
  • This is ridiculous! But this is definitely the workaround. The solution is to have the "configure import" feature fixed and/or the key CSV export fixed.

-1

I haven't tried this myself but you may need to specify that it's a "file" that you are passing the command. Have you tried something like:

aws configure import --csv file://C:\Users\system\Downloads\new_user_credentials-1.csv

Edited by: EvanH on Oct 9, 2020 8:26 AM

EvanH
answered 3 years ago
  • the "file://" prefix is irrelevant in this case. And it is not working anyway.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions