Magento 2.4.6 Port must be configured within host parameter (like localhost:3306

0

I have a Magento 2.4.6 website built using Amazon Lightsail, which is auto-configured. I’m installing MinimogMG theme, but I’m having trouble.

Port must be configured within host parameter (like localhost:3306

https://prnt.sc/lYTjNjn9-DGk

I followed the steps of the official tutorial. https://docs.bitnami.com/aws/apps/magento/configuration/install-theme/ https://www.youtube.com/watch?v=gpPJTfQoA0c&list=PLGgVZHi3XQNl2T8Q1RMfgLIop3TIFwVad&t=3s

How can i solve?

bitnami@ip-172-00-00-01:~/minimog_theme$ sudo /opt/bitnami/magento/bin/magento-cli setup:upgrade
Cache types config flushed successfully
Port must be configured within host parameter (like localhost:3306
In Abstract.php line 144:                                             
  SQLSTATE[HY000] [2002] Connection refused                                               
In Abstract.php line 128:                                             
  SQLSTATE[HY000] [2002] Connection refused                                               
bitnami@ip-172-00-00-01:~/minimog_theme$ 
Angelo
asked a year ago447 views
1 Answer
0

Are there any env.php or other files placed in app/etc/?
Edit the host parameter of the file to something like "localhost:3306".

profile picture
EXPERT
answered a year ago
  • Yes, I've tried editing app/etc/env.php, but the problem still doesn't work. https://prnt.sc/Tbr6D8Yq8a-k

  • How about running the following command to remove the cache?

    sudo rm -rf /opt/bitnami/magento/var/cache/*
    sudo rm -rf /opt/bitnami/magento/var/page_cache/*
    sudo rm -rf /opt/bitnami/magento/generated/*
    
  • I executed your code, but the problem is still not solved.

    I provide more server info at this link. https://github.com/bitnami/vms/issues/849

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions