By using AWS re:Post, you agree to the Terms of Use

Number of Assets per Sitewise project

0

Hello,
I'm trying to add multiple assets to a project using the BatchAssociateProjectAssets API: https://docs.aws.amazon.com/iot-sitewise/latest/APIReference/API_BatchAssociateProjectAssets.html, it looks like there is only one asset that can be added to a project. From the sitewise quotas page, it says,

Number of root assets per project 1

However the API accepts multiple assetId's : https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/iotsitewise.html#IoTSiteWise.Client.batch_associate_project_assets

So i'm a bit confused here, What exactly does a root asset mean, when i add assets which are from another asset hierarchy (non-root), i'm receiving the LimitExceededException, please can someone clarify,

  1. how many assets can be added to a project?
  2. and what exactly is a root and non-root asset in this case (I have tried adding both, and they failed)?

So, i'm only able to have only 1 asset added to a project, so i'm wondering whether a non-root asset can be added at all, if yes, how?

Thank you.

Simith
Rackspace Technology

Edited by: simithrackspace on May 24, 2021 8:39 AM

asked a year ago38 views
2 Answers
0

Hi Simith,

As of now, only one asset can be added to a project using the BatchAssociateProjectAssets API. This one asset is referred to as the root asset, and the project will then implicitly have access to all children of it in its asset hierarchy.

When you add an asset that is not in the asset hierarchy of the existing root asset associated with the project, you will receive the LimitExceededException due to the service quota of "Number of root assets per project: 1". You can either rearrange your asset hierarchy to include this asset in the existing root asset's hierarchy, or create a separate project to view this asset.

Thanks,
Ivan

answered a year ago
  • I am looking for clarification on this answer. I am in the same boat as Simith, where I have 3 assets that I am trying to add to a project in the SiteWise Portal, and I am getting the same error (too many assets). According to the documentation here: https://docs.aws.amazon.com/iot-sitewise/latest/userguide/add-associated-assets.html

    I should be able to create the hierarchy of assets by editing the Parent asset, and associating the Child asset to it. But when I create and then edit my Parent asset, I don't have the option to associate a child asset to the parent. The "Hierarchy" section in the screenshot doesn't show up for me. Did something change, or is there a problem on my end?

0

Thanks Ivan for your answer.

Simith
Rackspace Technology

answered a year ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions