By using AWS re:Post, you agree to the Terms of Use

EC2 instance rejecting connections after 7 minutes

0

When launching an EC2 instance, I can successfully connect to it for 7 minutes at a time. Then, it disconnects me and I have to stop and start the instance to allow connections again.

I've tried both Linux and MSWindows instances.I've tried SSM, SSH, and RDP (where appropriate)If I setup a cron job, pinging www.google.com, it still pings successfully, even though I get disconnected.

I have tried this from several machines and networks, to see if somehow my personal network is a problem. it doesn't seem to matter. 7 minutes after boot, I get disconnected and can't reconnect.

It doesn't matter if I have a lot of network traffic or a little.

Cloudtrail doesn't show anything in the timeframe.

I can also connect to other EC2 instances on other AWS accounts and stay connected for hours and hours.

Any idea on what could be causing my disconnects after 7 minutes?

  • The strangeness increases. Now I'm not able to connect to any instances at all. I've verified a public IP on a new instance, the Subnet has 0.0.0.0/0 routing to an internet gateway. Security group is wide open to ssh (0.0.0.0/0 in bound port 22), I've been working in us-east-1, but tried us-west-1, as well.
    I've setup a new VPC, subnets, and IGW. Same results. I can connect to other accounts instances.

  • What instance type(s) are you using?

2 Answers
0
Accepted Answer

I have heard back from AWS support on this. They report:

"I'd like to inform you that the team has reverted with an update. The team has stated that they have made some troubleshooting steps and they have resolved the issue."

And sure enough, it is now working as expected. So.... Attention future folks! Make sure that you've taken all the troubleshooting steps necessary, like NACL review, public IP for instance, Security Group open enough, internet gateway on the subnet, and any other possible technical reasons for failure. Then, even with the free 'basic' account, enter an "account and billing" ticket, explaining the problem. Then a few days later, after some back and forth, they'll fix your account.

I wonder if they isolated my account by accident?

answered 2 months ago
0

Seven minutes is an odd time; especially if it is consistent across operating systems; and that the instances continue to communicate even thought you can't connect to them.

Are you using a restrictive inbound security group for the instances? Is it possible that your public IP is changing (your ISP; upstream NAT devices) and that's causing the issue?

EXPERT
answered 2 months ago
  • Thanks for the response. I've got no restrictive inbound security group and the NACL is wide open, too. Security group is set to allow inbound port 22 from 0.0.0.0/0.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions