Cannot delete certificate from ACM

0

I have an old certificate in ACM which was created through Terraform, and is in the "Issued" state. Unfortunately, now I cannot delete it because it is shown as "In use", even though it's not, at least not by me. I tried deleting the certificate manually from the ACM console, but the deletion page shows that it is in use by account 061510835048, which is one of AWS's internal accounts (see https://docs.aws.amazon.com/apigateway/latest/developerguide/set-up-api-with-vpclink-accounts.html)

How can I unlink it? I have already tried deleting all my resources, but it seems something got stuck. I read that this can happen and normally it requires contacting the AWS customer service, but I don't have access to that. Can someone help?

This is blocking me because I cannot destroy resources and get back to a clean slate.

asked a year ago278 views
1 Answer
0

Are you using the certificate together with a custom domain in api-gateway (or another service)?

Removing the domain mapping from the API should make it possible to delete the certificate

EXPERT
answered a year ago
  • Yes, I am. Or I should say "was" because I deleted everything but still cannot delete the certificate. It's apparently stuck, linked to a ghost CloudFront distribution.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions