MediaTailor to Cloudfront to Route 53 using HTTPS / SSL - Any Suggestions? Domain Continues To Fail


I have a fully functioning MediaTailor instance distributing HLS content in .m3u8 - (public data removed): https://(my cloudfront alphanumeric)

I am trying to use a Route53 domain name to mask the cloudfront source:

I have registered a new domain with Route 53, I have created a SSL certificate, I have added the CNAME records to my Domain, I have added the Domain to the Cloudfront instance. Here are the results (which fail): https://(my dot com)/v1/nevermind/58a2f0c6b3528a8407e12e2dd992bd221d5afc39/RadFAST1-Channel-Beachfront/radfast1.m3u8

Does anyone have any suggestions / tips / ideas? I tried using a GoDaddy domain and found that that doesn't work for HTTPS. I purchased a domain from Route53 in hopes that the fact that AWS was hosting the domain would make this work, but no such luck. Is it my URL syntax from Cloudfront / Mediatailor?

Any assistance appreciated - I've been working on this for a week now.


2 Answers
Accepted Answer

Issue solved.

Here's how: when Route53 created the domain record the A name was set to https\072\057(my cloudfront distribution alphanumeric) - I figured that was correct because Route53 set in that way when I first registered the domain.

When I removed the "https\072\057" from the A name record and replaced it with (my cloudfront distribution alphanumeric) - everything worked including my HTTPS CNAME SSL.

answered a year ago


You'll probably want to remove your CloudFront link from this thread, or you could potentially incur unexpected costs from people watching your content as this is a public forum. Your domain does not DNS resolve for me at all, so I don't think a DNS record has been setup for it, or hasn't propagated yet.


answered a year ago
  • Dirk -

    Not so worried about people watching the content - it's a test stream. I've registered the domain in Route53 and added the CNAME records. I have screen shot of domain in Route53 but can't add it in comments. I've been messing with this for days and I feel like I'm missing something really basic - though for the life of me I can't figure out what it is. Trying not to get frustrated - but this is the last step of this build / test and it should be easy...any assistance appreciated.


You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions